Tuesday, February 21, 2017

Let's Encrypt Free A+ Grade SSL On Nginx & Ubuntu 16.04



Prerequisites:

LEMP on Ubuntu 16.04

Start by updating apt indexes

sudo apt-get update

Install Let's Encrypt Package

(Known as certbot on Github (https://github.com/certbot/certbot))
sudo apt-get install letsencrypt

Wednesday, February 15, 2017

Installing Wordpress on PHP7, Nginx & Ubuntu 16.04 With SSL Support


Nginx Wordpress Logo
This tutorial assumes you already have LEMP installed on Ubuntu 16.04 with PHP7 & PHP-FPM. If you don't have anything installed yet, you can find a tutorial on how to do it in here.

For this tutorial, I'll assume you are logged in as root. Ideally however, you must use a non-root username and prefix all the commands with sudo.

Update your packages

apt-get update && apt-get upgrade